Openstack dashboard gives error “Error: Unable to retrieve information”

So today i ran into one more issue with Openstack , the error showed up  when i logged in to the dashboard and clicked on Project–>Instances.

What i saw terrified me because is saw “NOTHING” !

A day before i had the same issue and i thought it’s related to RAM so i restarted and everything started and operated normally, but this time the reboot didn’t help.

So i started scratching my head and started wondering what might be the reason. I searched internet but no success. I searched log files but nothing made sense at that time, so i rebooted one more time and an Error appeared saying something like “Openstack glance-registry api error limit reached ” So that gave me a head start that it has something to do with system being low in space.

A df -h showed that / is 100% full. I removed some unnecessary files , rebooted the system and Viola !

All started to work Normally.

Conclusion:

Make Sure you have enough space with OpenStack

 

Unable to Connect “The Squid Error “

So today i had a strange problem when i was only able to access google.com and not other sites. I was able to browse gmail, but not mail ru. Everything was working fine but out of no where this error “Unable to Connect” appeared on my Browsers. It was kinda strange, since i made no changes to my system” Also i was not sure if it’s the system or the Gateway.
Observation on System:
1) Both Firefox and Chrome giving the same problem.
2) I was able to browse with Chrome if Ultrasuf Extension was enabled.
3) Firebug reported “Aborted” in the Net tab

Steps taken:

Restarted the System
Changed the IP address
Result:
System Not Fixed Continue reading

Solving Call Drop Issue in Elastix / Asterisk

If you change your Network and you find that the working Elastix / Asterisk box is now dropping calls every 15 to 25 secs.  One of the most probable reason is “NAT” .

The solution which worked for me is changing the sip_custom.conf found in /etc/asterisk/ directory.

Open it with your favorite editor such as vim or nano and add the following lines.

externip=1.1.1.1/255.0.0.0  < Your External Ip with Subnet Here >
localnet=192.168.1.0/255.255.255.0 < Your Internal Ip with Subnet Here >
canreinvite=no
NAT=Yes
Qualify=yes
promiscredir=yes

Hope this will help someone.

Thanks,
Salman

Have a Question ? Need Consultancy ? Contact US

Hi Guys , you know that you can ask for free or get free consultancy form us. So, if you want to consult with us regarding Network Setups, Linux , Security and Web Development projects Feel free to ASK !.

Here is how you can Ask !

YouTube: www.youtube.com/linuxking
Facebook Page: www.facebook.com/linuxking77
Facebook Group: www.facebook.com/groups/LZHProject/
Website: www.itpings.com

Thanks,
Sal

Word Press Plugin Install Error

Hey Guys , so i installed WordPress on Centos 7 and it was successful, but then i faced an Error while installing the plugins. The Error was “Unable to locate WordPress Content directory (wp-content”

It asked to connect with FTP , but kept on failing.

Solution:

Just Give apache permission to www directory and the content beneath it.

[root@itpings]# chown -R apache.apache -R www/ <--- Now Restart httpd [root@itpings opt]# systemctl restat httpd.service <-- Now Try to download the plugin and should work. Thanks, Salman Francis.